Can-Am ATV & UTV Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
62 Posts
Discussion Starter · #1 ·
I have a 07 Outlander 800 LTD Max with over 5k miles on it. Last week I went for a trail ride and after about ten miles it starter crapping out along with some back fire I could tell it wasn't getting enough fuel. After setting for awhile it started and ran fine for a short distance and continued to get worse and barely made it back to my truck. When I got home I replaced the fuel filter and noticed the old one had some restriction of flow thinking this was the fuel problem.
Today I took it back out on the trail and after about eight miles it started crapping out again until it shutdown. After waiting a few minutes it fired back up and ran good for a bit and then started doing it again. The rest of the way back to my rig was startup,run until out of gas and wait over and over each time going a shorter distance before it quitting. When I got home I checked the new fuel filter and there was no restriction of fuel and had good flow. I cut the old filter can in half looking for dirt but didn't see any particles in it.
My question is does this sound like my fuel pump is going bad? I can not find any fuel leaks that would cause the loss of fuel pressure, Every time I start it I can hear the fuel pump run for a couple seconds. I don't have the pressure test tools to check the fuel pressure. Does this fuel problem sound familiar to anyone?
Thanks
 

·
Moderator
Joined
·
2,861 Posts
Sounds exactly like a fuel pump issue, but I'd double check to see if there's any water in the tank first.

To replace the pump in the early models, you have to remove the fuel tank and tank guard, as the pump is mounted in the lower part of the tank.

I've had good results from various ebay suppliers of pumps.
 

·
Registered
Joined
·
18 Posts
It for sure could be a fuel pump going out when getting warm. First thing I would check is the one way valves in the tank breather line. If it's clogged, it will create a vacuum when the pump runs. The line is there to let air into the tank when fuel is used up to prevent a vacuum. You should be able to blow through it into the tank but not the out of the tank direction.
 

·
Registered
Joined
·
4,536 Posts
most definitely a fuel pump issue and as Oz said the tank will have to come out because its a bottom fed tank. I have a brand new OEM pump assembly, regulator, pick up and filter. i also have brand new new rubber gaskets and bolts to go with it. i had planned on switching one of my machines over to a bottom feed tank due to the bigger size but have shelved that idea for now. i have about $360 bucks into it now but would be willing to part ways with it for $230 shipped, if your interested in it PM me and i can ship it out.
 
1 - 4 of 4 Posts
Top