crewdog506 - Viewing Profile: Likes - can-am ATV Forums - can-amtalk.com

Jump to content

 




 
 
 

crewdog506

Member Since 25 Apr 2008
Offline Last Active Jul 02 2020 09:57 PM
-----

#799801 New rig...questions

Posted by crewdog506 on 10 July 2016 - 02:50 PM

Quiet is awesome!


#794674 !!!help!!! New solenoid clicks!

Posted by crewdog506 on 23 May 2016 - 03:29 PM

Sounds like you have a wire on the solenoid on the wrong post...one of the small wires...


#792393 2017 BRP Lineup?

Posted by crewdog506 on 11 May 2016 - 07:57 PM

You know, short mag emailed me a few days ago and asked if I sold the renegade, which I haven't. Havent even tried. That being said, this thread brings up a good point...while I am no drinking rider, I have lost interest in riding the quad. Not because I don't like riding, because no one rides like I want to ride around here. Riding by myself has become boring, and the groups I ride with don't "ride." I could honestly get more use from a commander. I've ridden the renegade twice this year, less than 100 miles total. I've had it almost 2 years and it has 800 miles on it...seems like its a waste of time to have it, and it's for sure in the way...that being said, I may decide to move on and sell it.

Its a shame, but I think quads are just about done...


#785618 Nothing Changes

Posted by crewdog506 on 09 April 2016 - 08:56 PM

One issue I had years ago was the "selective" moderation. Some people could type anything they wanted, yet others were suspended for a week or two for responding. That was it for me. This thread is going to die as well...just like everything else. The facebook stuff is okay, at best, but it has its downfalls too. This site will never be the site it once was... too much politics!


#785394 Nothing Changes

Posted by crewdog506 on 08 April 2016 - 06:03 PM

I check the site about once a week. Not for info...but for stupid crap going on. That's the only enjoyment for me. I've lost interest in riding, lost interest in nodding, lost interest in a lot of stuff in the last year. Was a tough year. That being said, bigger, better things on the horizon.

Oh, and I like my bone stock xxc. No need for mods, works great as is. I laugh at the clutch threads...'cause there are more stockers out there turning than over priced Polaris parts...

Stock works...period...and it's reliable.


#784745 Charging voltage

Posted by crewdog506 on 05 April 2016 - 06:49 AM

Send 7shortmag a message. He may be able to lead you in a direction.


#781834 Can't get the inner half of the primary clutch off

Posted by crewdog506 on 21 March 2016 - 10:01 AM

Grease is easier than water, but water cleans up a whole lot easier! With water, you'll have to tip the machine on its side. With grease, you'll want to get every trace of it out of there...


#769033 10 hour Valve Adjustment?

Posted by crewdog506 on 24 January 2016 - 09:03 AM

Wow...that's some bad advice right there! Everytime I have checked my valves, over 8 years of owning a can-am, they are out. They always get tighter.

As a side note, there was a 10hr valve adjustment on the 08 machines, can't remember with my 14.


#765706 Fuel additives

Posted by crewdog506 on 02 January 2016 - 03:22 PM

They need to be schooled... no need for higher octane unless you are running higher compression. Higher octane fuels are said to have less ethanol, but I've never seen any proof. Your owners manual even mentions the fuel requirements in it...


#765426 Fuel additives

Posted by crewdog506 on 01 January 2016 - 02:55 PM

Higher octane is a waste of money...it's not required...

I personally use an Amsoil product. Can't remember the name though, quick shot maybe?


#749313 heating

Posted by crewdog506 on 25 October 2015 - 07:40 PM

On each head, there is a hose connection. On that connector, there is a small 8 mm screw. You have to crack those loose to bleed the head...if not, you'll never get rid of this issue. Be careful with them though, the connector is plastic and is probably pretty easily broken. I'm sure there are pictures on the site somewhere of the screws.


#749297 heating

Posted by crewdog506 on 25 October 2015 - 07:24 PM

The bleed ports on the heads need cracked and bled, id bet. I have always had better luck with bleeding the system with the front of the quad raised a foot or so. Your not over heating...the cooling system has a bubble in the rear head and the steam is causing the sensor to think the engine is over heating.


#747170 Got Bored Yesterday

Posted by crewdog506 on 18 October 2015 - 09:53 AM

My eyes are getting worse at night... no need for leveling kits, as most of them don't level the truck anyway. Most of them lift the front too much and cause the headlights to be severely out of whack. This is just as bad in the car as it is in the truck, so don't say quit driving a car...


#747130 Got Bored Yesterday

Posted by crewdog506 on 18 October 2015 - 08:19 AM

Leave the leveling kit out or just lift the entire truck. They should outlaw leveling kits!


#733009 07 Max Xt Headlights and Winch wont work

Posted by crewdog506 on 01 September 2015 - 08:14 PM

All of your issues run on the same circuit I believe...whatever issue you have, I'd say it's directly under the fuseblock or in the associated wiring to one of those items. 4wd actuator, headlights, winch, accessories are are common issues for wiring troubles.