Clutches - Outlander discussion - can-am ATV Forums - can-amtalk.com

Jump to content

 




 
 
 

Photo
- - - - -

Clutches


  • Please log in to reply
2 replies to this topic

#1 Countryboy72

Countryboy72

    Member

  • Members
  • PipPip
  • 22 posts
  • Your Ride:Outlander 400

Posted 23 July 2019 - 04:25 PM

Rebuilt clutches on 400 and new belt now it feels kinda doggy, doesn’t seem too rev up like it used too as fast and doesn’t have the same tire spin feel it usually does, and top end kinda seems slow now. Did I mess something up


Sent from my iPhone using Tapatalk

#2 GYPSY400

GYPSY400

    Advanced Member

  • Members
  • PipPipPip
  • 288 posts
  • Your Ride:2003 Outlander 400

Posted 26 July 2019 - 12:39 PM

Most likely

Sent from my SM-G903W using Tapatalk
GYPSY400

2003 Outlander 400 4X4

www.outlander400.piczo.com
quite possibly the O-400 Guru??

#3 ozymax

ozymax

    Ozy for short.

  • Moderators
  • PipPipPip
  • 2854 posts
  • Gender:Male
  • Location:Cairns, Australia
  • Interests:Quad riding.
    Geocaching.
    Radio controlled helicopters.
    Hiking.
    4x4 touring this great country.
  • Your Ride:2012 G2 Outlander 650 Max XT

Posted 26 July 2019 - 07:03 PM

I've been trying to find an old topic that came up about this ages ago, but can't seem to locate it.

The original owner o'hauled his clutches and when he re-assembled the primary clutch, he didn't have one of the fly weights

sitting in place properly.

Might pay to rip the cvt cover back off and double check.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users