Jump to content

 




 
 
 

Photo
- - - - -

2005 Rally - need help

Rally 200

  • Please log in to reply
1 reply to this topic

#1 macadoo

macadoo

    Newbie

  • Members
  • Pip
  • 1 posts
  • Your Ride:wolverine

Posted 21 May 2017 - 10:48 AM

I am looking at 2005 Rally that is extremely clean however when I went to look at it the machine wouldn't start.  He said it has sat for about 9 months so guessing bad gas and dirty carb.  It cranks over just fine but seems to have no life.  We took the air filter out and tried starting fluid, it came to life for a few seconds then shut down.  After sitting for  awhile it would start and run for a few seconds but wouldn't stay running.  After doing research all I hear is bad things about the Rally but I get the web usually post problems so not sure if I should be worried that it is more than a carb issue.  I read timing chain and valves are know issues which concern me about not starting so all I can think of is to do a compression test.

 

Looking for suggestions....appreciate the help.



#2 kartking

kartking

    Newbie

  • Members
  • Pip
  • 9 posts
  • Your Ride:2005 Rally

Posted 29 May 2017 - 07:12 PM

My brother in law bought a 2005 brand new and i have a 2006 which i purchased used...

the only issues i know of is 

1. if the battery goes dead/very low u will kill the CDI box

2. the transmission break if not used properly...i.e not waiting for the revs of the motor to go down before shifting into a gear

 

Other than those 2 things i find the ATV to be bullet proof and trust me we have put them through some rough tests...up north Canada can be very hard on an ATV...

 

Hope this helps.... 






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users